X-SERVERでもAWS SDK for PHP バージョン 3を使いたい

要約
・X_SERVERはbashからだとphp5.4が動いてしまう(現在問い合わせ中->回答あり)
・composer requireするとSDK バージョン 2が入ってしまう
amazonからzipファイルをダウンロードしてくるしかない。※左ページ最下部からダウンロードしてください。
・wordpress内ではzip内のautoload.phpをreqireすべし

最近X_SERVERネタが多いですが、特に押しているわけではありません。
お客様要件でさわっている。
でもX_SERVERのことをだんだん好きになっている自分がいます。ハロー効果なのか?

X-SERVERからすぐ回答がありました。
やはり7.2などを付けて動かさないといけないようです。
しかしお問い合わせ窓口も回答待ちの時間が少なくて良いな~。
自社のサイトもVPSで運用する必要ないしX-SERVERに引っ越そうかな・・・。

******
お問い合わせいただきありがとうございます。

お手数ではございますが、このような場合
サーバーパネル『サーバー情報 > コマンドパス一覧』をご確認いただき、
各PHPバージョンに適したコマンドパスを使っての実行をお願いしております。

※ 「/usr/bin/php7.2 -v」などと実行

※ サーバーパネル『PHP Ver.切替』や『php.ini設定』はいずれも
  WEB上からPHPへアクセスしたときに有効となる設定です。
******

Leave a Comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です